nixos-config/hosts/envy/default.nix
2025-03-08 05:36:01 -05:00

37 lines
809 B
Nix

{ config, lib, ... }:
{
imports = [
./boot
./disko
./filesystems
./hardware
./users
../../modules/system
];
networking = {
hostName = "envy";
wg-quick.interfaces.wgc.address = [ "10.100.0.25/24" ];
};
system = {
desktop.enable = true;
lanzaboote.enable = true;
fancyboot.enable = true;
wireless.enable = true;
wireguard.client.enable = true;
libvirtd.enable = true;
stateVersion = "24.11";
};
# Services to make this work as a school laptop
services.globalprotect.enable = true;
virtualisation.vmware.host.enable = true;
nixpkgs.allowUnfreePackages = [ "vmware-workstation" ];
environment.persistence."/persist".directories = [
"/home/${config.sysusers.main}/vmware"
"/home/${config.sysusers.main}/.vmware"
];
}