nixos-config/modules/system/devices/boot/plymouth/default.nix

16 lines
332 B
Nix

{ config, lib, ... }:
{
config.boot = lib.mkIf config.boot.plymouth.enable {
consoleLogLevel = 0;
loader.timeout = 0;
initrd.verbose = false;
kernelParams = [
"quiet"
"splash"
"loglevel=3"
"rd.systemd.show_status=false"
"rd.udev.log_level=3"
"udev.log_priority=3"
];
};
}