nixos-config/modules/system/devices/video/nouveau/default.nix
2025-02-02 13:42:37 -05:00

10 lines
298 B
Nix

{ config, lib, pkgs, ... }:
{
options.system.video.nouveau.enable = lib.mkEnableOption "Enable the Nouveau graphics stack";
config = lib.mkIf config.system.video.nouveau.enable {
services.xserver.videoDrivers = [ "nouveau" ];
boot.kernelParams = [ "nouveau.config=NvGspRm=1" ];
};
}